Critical Time Loop Device does not work

View previous topic View next topic Go down

Critical Time Loop Device does not work

Post  Deuced on Sun Nov 24, 2013 5:24 pm

My Critical Time Loop Device fails to activate in all modes for all my ships.

They only time I've seen it activate is during the story missions which gave you the device.

Deuced
Guest


Back to top Go down

Re: Critical Time Loop Device does not work

Post  Paul Dryere on Sun Nov 24, 2013 7:04 pm

Hey Deuced,

I cannot replicate this behavior on my end. The ability can only activate once every 30 seconds, and it is possible to not notice when it first activates (if in a particularly frenetic battle). You can double check that you have the ability while playing by pausing and accessing the bindings menu. Scroll down to your passives and make sure you have Critical Time Loop. If for some reason you don't and are sure you have equipped the device onto your ship, then I will have to look into what could possibly be the problem.

Paul Dryere

Posts : 504
Join date : 2012-02-28
Age : 30

View user profile

Back to top Go down

Re: Critical Time Loop Device does not work

Post  Deuced on Sun Nov 24, 2013 8:41 pm

Yes I have it equipped. It's displayed in the binding menu.

May I send you my save files so you could look into it?

Deuced
Guest


Back to top Go down

Re: Critical Time Loop Device does not work

Post  Paul Dryere on Sun Nov 24, 2013 9:07 pm

Sure. Just send them to RRCrashReport@gmail.com

Also, it would help if you could tell me a specific mission that you are certain the ability isn't working on.

Paul Dryere

Posts : 504
Join date : 2012-02-28
Age : 30

View user profile

Back to top Go down

Re: Critical Time Loop Device does not work

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum