Shop screen graphical glitch

View previous topic View next topic Go down

Shop screen graphical glitch

Post  Strudel Meister on Sun Mar 03, 2013 12:57 am

Whenever i go into the shop screen, it works fine until the 3D model in the background (due to the nature of this glitch, i don't know what it is) loads. then all of the menu buttons and the model itself turn entirely black. I've found that this carries over to all other menus until in restart the game. im not sure if it happens on other menus as i have only just downloaded and played the tutorial, but it seemed to work fine until i checked the shop.

Thank you for any assistance you provide.

Edit: i've found the same glitch happens just as the playable part of the campaign begins. i fear it might have something to do with model complexity and my graphics card (the specs of which i am unsure of), although what seems to be the offending model (the ship i'm escaping from) is still properly textured.

Strudel Meister

Posts : 5
Join date : 2013-03-03

View user profile

Back to top Go down

Re: Shop screen graphical glitch

Post  Paul Dryere on Sun Mar 03, 2013 1:42 am

Does this happen every time you have tried?

Also, could you check if the same error occurs when you attempt to Customize Hull in the Hangar.

Could be some sort of graphics card driver issue with the wireframe shader used to render those models.
avatar
Paul Dryere

Posts : 504
Join date : 2012-02-28
Age : 30

View user profile

Back to top Go down

Re: Shop screen graphical glitch

Post  Strudel Meister on Sun Mar 03, 2013 3:03 am

Yes, i have tried dozens of times, on both the shop an the first mission, with the same result.
The hangar works fine, however.

Edit:
My graphics card, if it helps: Mobile Intel(R) 4 Series Express Chipset Family (Didn't find it on the list of working cards, still hopeful )
I am using a laptop with a secondary monitor, though i turn the monitor of while playing games.

Strudel Meister

Posts : 5
Join date : 2013-03-03

View user profile

Back to top Go down

Re: Shop screen graphical glitch

Post  Paul Dryere on Sun Mar 03, 2013 3:46 am

So in the hangar, you can press the Customize Hull button and see the wireframe for the hull just fine? Hmm, from everything else it seems like it is a problem with the wireframe shader. In which case I could add an option to simply not display UI wireframes.
avatar
Paul Dryere

Posts : 504
Join date : 2012-02-28
Age : 30

View user profile

Back to top Go down

Re: Shop screen graphical glitch

Post  Strudel Meister on Sun Mar 03, 2013 4:00 am

Affirmative, i'm the kind of guy that reads a games flavor texts for hours, so ive spent a decent deal of time in the hanger, even though i cant buy anything to build with.

if it'd make the shop work for me, im all for it! could you tell me what else uses wire frames in the game first? so i could try loading those and confirm that that's the problem?

it might also be relevant that im using the demo off of IGN, as my interest for this game began while the episode of game boss was still underway, barring me from the true demo.

Strudel Meister

Posts : 5
Join date : 2013-03-03

View user profile

Back to top Go down

Re: Shop screen graphical glitch

Post  Paul Dryere on Sun Mar 03, 2013 3:00 pm

Hmm, the demo for IGN didn't suppose to have the shop or hangar unlocked. scratch

UI wireframes are used in equipment/hull inspection, the shop screen, the hangar customize screen, and the minimap/map on certain missions. Try running a spire battle scenario if you can, they are definitely used in that mission.

Also, could you grab a screen shot of the glitch?

The actual demo should be available to the public through our site sometime tonight.
avatar
Paul Dryere

Posts : 504
Join date : 2012-02-28
Age : 30

View user profile

Back to top Go down

Re: Shop screen graphical glitch

Post  Paul Dryere on Sun Mar 03, 2013 3:25 pm

I posted the demo, you can access it through our main page by clicking the Alpha Demo button in the top left corner.

Make sure to uninstall the IGN demo before downloading it.
avatar
Paul Dryere

Posts : 504
Join date : 2012-02-28
Age : 30

View user profile

Back to top Go down

Re: Shop screen graphical glitch

Post  Strudel Meister on Sun Mar 03, 2013 3:31 pm

it isnt? strange that it works for me...

all of those other screens work fine for me. im starting to doubt its the wireframes.

Sure, here:


that image is after the glitch has happened. all screens look and work just as they should other than the first campaign mission before it happens. although the black UI maintains on all other screens until the game is restarted.


. i can not get an image of the ingame glitch as my computer has a stroke every time i try doing more than one thing Smile

Strudel Meister

Posts : 5
Join date : 2013-03-03

View user profile

Back to top Go down

Re: Shop screen graphical glitch

Post  Paul Dryere on Sun Mar 03, 2013 3:55 pm

Hmm, that is a new one. Shocked

Would you mind giving the full demo a shot and see if it resolves it? Might have been some install error for the IGN demo, since it didn't suppose to include the shop anyway. Smile

Just make sure to uninstall the current version before downloading the new.
avatar
Paul Dryere

Posts : 504
Join date : 2012-02-28
Age : 30

View user profile

Back to top Go down

Re: Shop screen graphical glitch

Post  Strudel Meister on Sun Mar 03, 2013 4:50 pm

after a full reinstall, the game still behaves the same Sad

i notice that the demos version tag that showed for me (9.1.1.0) is the same as the one i got from ign. i kinda suspect there was an error with the ign download that gave me the regular demo or i reinstalled incorrectly, but thats beside the point now.

it seems to be a problem with the shop screens programming. whats different about that screen from the others? id assume its in the render code, because the shop functions normally until the models load in (though ive found the shop preview wire frames for items are textured for a split second before the ui goes black, but not whatever model loads initially).

i was having trouble finding the directory the game was in, but by finding file location from the task manager, i got to C:\Users\(User)\AppData\Local\Apps\2.0\7BNEX0MA.9PJ\ONV58Y5W.94K\ring...exe_393e28d0f9fa8bd7_0000.0009_none_8d22e98722d6986a . i could not find any uninstall exe so i just deleted C:\Users\(User)\AppData\Local\Apps\2.0 and hoped for the best reinstalling.

how should i uninstall? or did i do it right?

and really, i must thank you for your persistent support with my problem, its much appreciated Smile

Strudel Meister

Posts : 5
Join date : 2013-03-03

View user profile

Back to top Go down

Re: Shop screen graphical glitch

Post  Paul Dryere on Sun Mar 03, 2013 5:02 pm

No problem, the game is in alpha and its my responsibility to make sure it works on the most systems as possible. Smile

You should be able to uninstall via the control panel add/remove programs. I'll take a look at the shop screen a bit more. Though the problem doesn't occur on any of my test machines, so I will be shooting in the dark a bit.

I'll add an option to disable UI Wireframes in the next patch just in case.
avatar
Paul Dryere

Posts : 504
Join date : 2012-02-28
Age : 30

View user profile

Back to top Go down

Re: Shop screen graphical glitch

Post  EvilNinjadude on Sun Mar 03, 2013 5:06 pm

You can always uninstall from the Control Panel.

So, the Alpha is back up because the voting is over? Good to know. And you with the awesome name, say you have somehow gotten the full install? hm. Interesting.
avatar
EvilNinjadude

Posts : 550
Join date : 2012-10-04

View user profile

Back to top Go down

Re: Shop screen graphical glitch

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum